Installation

Composer

The extension can be installed through composer:

composer require "codappix/search_core" "~0.0.7"

Note that you have to allow unstable packages:

{
   "minimum-stability": "dev",
   "prefer-stable": true
}

Download

You can also download the extension and placing it inside the typo3conf/ext-Folder of your installation. In that case you need to install all dependencies yourself. Dependencies are:

Dependencies from composer.json
"php": ">=7.0.0",
"typo3/cms": ">= 7.6.0 < 9.0.0",
"ruflin/elastica": "~3.2"

Setup

Afterwards you need to enable the extension through the extension manager and include the static TypoScript setup.

If you don’t want to use the included Elasticsearch integration, you have to disable it in the extension manager configuration of the extension by checking the checkbox. It’s currently enabled by default but will be moved into its own extension in the future.